Issue viewing usage dashboards in Port

Incident Report for Port

Resolved

The issue is resolved, usage dashboards will now work as expected
Posted Aug 05, 2026 - 12:18 UTC

Investigating

We are currently investigating an issue preventing data from loading in the usage dashboard page

The source of the issue is a problem with our 3rd-party analytics platform, we are working with them to resolve the issue

All other Port functionality remains available
Posted Aug 05, 2026 - 09:33 UTC
This incident affected: EU (Web UI) and US (Web UI).