Integrations sync status page not working

Incident Report for Port

Resolved

A fix for this issue has been deployed.
Posted Sep 18, 2025 - 12:59 UTC

Update

We are continuing to investigate this issue.
Posted Sep 18, 2025 - 12:58 UTC

Investigating

We are investigating an issue with Integrations status page not working.
Posted Sep 18, 2025 - 11:00 UTC
This incident affected: EU (Hosted Integrations) and US (Hosted Integrations).