Delays in updating global search in EU

Incident Report for Port

Resolved

The issue has been resolved. A fix was applied, and entities now appear in search results without delay.
Posted Nov 20, 2025 - 02:30 UTC

Investigating

We're currently investigating an issue causing entities to appear in the global search results with a delay.
It might also affect searching for entities in the top bar search.
Posted Nov 19, 2025 - 16:30 UTC
This incident affected: EU (UI Global Entities Search).