Delays in updating global search in EU

Incident Report for Port

Resolved

This incident has been resolved.
Posted Nov 09, 2025 - 20:16 UTC

Monitoring

A fix has been implemented, and we are monitoring the system performance.
Posted Nov 09, 2025 - 20:03 UTC

Update

We are continuing to investigate this issue.
We will provide more information as we have it.
Posted Nov 09, 2025 - 19:21 UTC

Update

We are continuing to investigate this issue
Posted Nov 09, 2025 - 14:58 UTC

Investigating

We’re currently investigating an issue causing entities to appear in the global search results with a delay.
This incident is only affecting the EU region. US search is working as expected.
Posted Nov 09, 2025 - 13:29 UTC
This incident affected: EU (UI Global Entities Search).