Issues with Self Service Actions

Incident Report for Port

Resolved

This incident has been resolved.
Posted Aug 17, 2025 - 11:35 UTC

Investigating

We are currently investigating an issue with running self service actions.
Posted Aug 17, 2025 - 11:06 UTC
This incident affected: EU (Self-Service Actions) and US (Self-Service Actions).