Issue with Audit logs in the UI

Incident Report for Port

Resolved

This incident has been resolved.
Posted Jul 26, 2026 - 15:50 UTC

Monitoring

A fix has been implemented, and audit logs are working again via the UI.
We are monitoring the system to ensure stability.
Posted Jul 26, 2026 - 14:36 UTC

Identified

We have identified an issue with viewing audit logs in the UI and are working on a fix
Posted Jul 26, 2026 - 14:25 UTC
This incident affected: EU (Audits) and US (Audits).