Issue accessing Port's UI in EU and US

Incident Report for Port

Resolved

The issue has been resolved, the system is fully operational.

We apologize for the inconvenience.
Posted Feb 19, 2026 - 15:03 UTC

Monitoring

The UI is operational again, we are continuing to monitor
Posted Feb 19, 2026 - 14:52 UTC

Identified

We have identified the issue and are deploying a fix.
Posted Feb 19, 2026 - 14:44 UTC

Investigating

We are currently investigating an issue accessing Port's UI.

Port's API, integrations, actions and automations continue to operate as expected
Posted Feb 19, 2026 - 14:32 UTC
This incident affected: EU (Web UI) and US (Web UI).