US general slowness

Incident Report for Port

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 22:08 UTC

Monitoring

Another fix has been implemented, and we are seeing recovery signals.
We continue to monitor the system until it performs full recovery
Posted Feb 25, 2026 - 20:57 UTC

Investigating

We are still seeing errors and continue to investigate this issue.
More updates will be provided as soon as they are available.
Posted Feb 25, 2026 - 20:02 UTC

Monitoring

The team has applied another fix, and the system is showing recovery.
We are monitoring the system health to ensure resolution.
Posted Feb 25, 2026 - 18:52 UTC

Update

We are continuing to investigate this issue.
Posted Feb 25, 2026 - 18:32 UTC

Investigating

The fix has lead to a partial recovery, and the team continues to investigate the issue.
We will provide more updates as we have them.
Posted Feb 25, 2026 - 17:19 UTC

Monitoring

A fix has been implemented, and we are monitoring the system to ensure resolution.
Posted Feb 25, 2026 - 16:40 UTC

Update

We are seeing degraded performance in Self Service actions.
We continue to investigate this issue.
Posted Feb 25, 2026 - 15:51 UTC

Investigating

We're currently investigating an issue related to US general slowness
Posted Feb 25, 2026 - 15:07 UTC
This incident affected: US (Web UI, Self-Service Actions).