New SaaS integration installations are stuck on "Creating"

Incident Report for Port

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 11:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2026 - 11:18 UTC

Identified

We've identified the issue, working on a fix
Posted Mar 16, 2026 - 11:07 UTC

Update

We have identified that the incident only affects EU based customers.
Posted Mar 16, 2026 - 10:28 UTC

Investigating

We are currently identifying the root cause of the incident
Posted Mar 16, 2026 - 10:22 UTC
This incident affected: EU (Hosted Integrations) and US (Hosted Integrations).