Audit API Latency Issues

Incident Report for Port

Resolved

The incident has been resolved and service performance has returned to normal. We are continuing to investigate the root cause and will keep monitoring latency to ensure stability.
Posted Nov 24, 2025 - 19:16 UTC

Investigating

We are currently investigating increased latency affecting the Audit API. Our engineering team is actively working to identify the root cause and restore normal performance.
We will provide updates as more information becomes available.
Posted Nov 24, 2025 - 18:42 UTC
This incident affected: US (Audits).